6 November 2014

Authorize.Net Update

6 November 2014,
 0

Platypus 5 users affected by the discontinuation of SSLv3 support from Authorize.Net can obtain a plug-in from support to restore credit card functionality.  We […]


5 November 2014

Authorize.Net / Platypus 5.0 and Below

5 November 2014,
 0

Recently, a vulnerability in SSLv3 was discovered and exploited using an attack method called POODLE.  Due to this vulnerability, many service providers have decided to […]


29 November 2010

Platypus 7 – Available Now

29 November 2010,
 Off

Big news for Platypus users – Platypus 7 has been approved by the PCI Security council and is scheduled for a January release! The […]